Reduced Support Availability

Incident Report for Fasthosts

Resolved

Majority headcount has been restored to the support team affected by the Earthquake. Note headcount is not at 100% so there could still be some delays on phones and email.

We appreciate your patience and understanding.
Posted Oct 13, 2025 - 11:26 BST

Investigating

Following an earthquake that has affected some of our support teams, we are experiencing delays.

Phone & Email Support: Calls are being rerouted to an alternative team. Please expect longer than usual wait times for responses.
Posted Oct 12, 2025 - 18:25 BST
This incident affected: Hosting (Webhosting) and Customer Services (Phone Systems, Email Support).