Intermittent bouncebacks on some mailboxes
Incident Report for Fasthosts
Resolved
This incident has been resolved.
Posted Nov 05, 2024 - 16:01 GMT
Investigating
Some customers may be getting bouncebacks when sending email to mailboxes hosted with Fasthosts. These will have a message like "Temporary Lookup Failure". If the email is re-sent it will usually get through on the second or third attempt.
We are currently looking into the cause of this problem.
Posted Oct 21, 2024 - 17:56 BST
This incident affected: Email (Receiving Mail).