Core VPS Provisioning Issue

Incident Report for Fasthosts

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 08:14 BST

Investigating

Currently customers may face issues with VPS products provisioning. Our engineers are aware of the issue and are working to resolve the issue.
Posted Aug 26, 2025 - 19:24 BST
This incident affected: Servers (Virtual Private Servers).