Longer wait times due to severe weather conditions

Incident Report for Fasthosts

Resolved

Majority headcount has been restored to the support team affected by severe weather. Note headcount is not at 100% so there could still be some delays on phones and email.

We appreciate your patience and understanding.
Posted Nov 04, 2025 - 17:15 GMT

Investigating

Customers may experience longer wait times than usual due to severe weather in some of our customer service locations. If your issue is not urgent please send your query via email to support@fasthosts.com.
Posted Nov 04, 2025 - 07:48 GMT
This incident affected: Customer Services (Phone Systems, Chat Support).