Service Outage - Customer Support Phone Lines Unavailable

Incident Report for Fasthosts

Resolved

The disruption affecting the Support Hotline has been resolved. It is now functioning normally again.
Posted Nov 26, 2025 - 14:33 GMT

Identified

Due to a technical disruption, the Support hotline is temporarily unavailable. As an alternative, you can use numbers 01452 947424 (for sales) and 01452 947421 (for support).

We apologize for any inconvenience during these brief technical difficulties and appreciate your patience and understanding.

You may also contact our support team via e-mail or chat.
Posted Nov 26, 2025 - 14:18 GMT
This incident affected: Customer Services (Phone Systems).