Sending email to Microsoft-hosted email addresses may not be possible

Incident Report for Fasthosts

Resolved

The issue has been resolved.
Posted Jan 09, 2026 - 10:41 GMT

Update

We have successfully minimised the disruption and are working to completely resolve it as soon as possible.
Posted Jan 08, 2026 - 16:58 GMT

Identified

Some emails sent to Microsoft-hosted email addresses may be rejected due to Microsoft blocking some of our IP addresses.

We are in contact with Microsoft to request de-listing.

Please accept our apologies for any inconvenience you may be experiencing.
Posted Jan 07, 2026 - 11:47 GMT
This incident affected: Email (Standard Email, Sending Mail).