Reduced Support Availability

Incident Report for Fasthosts

Resolved

Majority headcount has been restored to the support team affected by the Earthquake so rerouting has been removed, Note headcount is not at 100% so there could still be some delays on phones and email.

We appreciate your patience and understanding.
Posted Oct 10, 2025 - 17:22 BST

Identified

Following an earthquake that has affected some of our support teams, we are experiencing delays.

Phone & Email Support: Calls are being rerouted to an alternative team. Please expect longer than usual wait times for responses.

Chat Support: This service has been temporarily disabled.

We appreciate your patience and understanding.
Posted Oct 10, 2025 - 07:39 BST
This incident affected: Customer Services (Phone Systems, Chat Support, Email Support).