Intermittent errors when accessing email (includes webmail, IMAP and POP connections)
Incident Report for Fasthosts
Resolved
Incident has now been resolved - if you have any further issues please contact support.
Posted May 16, 2022 - 20:51 BST
Update
We have identified a faulty SSD in the array causing excessive read/write delays. This has been removed pending replacement.
Posted May 16, 2022 - 16:32 BST
Identified
Customers may experience a timeout when connecting to IMAP and POP, or a 504 error when using webmail.

A temporary workaround is to refresh the webmail page, or retry the IMAP/POP connection.
Posted May 16, 2022 - 14:32 BST
This incident affected: Email (Webmail Interface, Standard Email).